Zum Inhalt springen

Neuste Kommentare

  • Alexander Krüger: Hi Ich hab n Frage…Wenn ich bei adfly links... 26. September 2016
  • Rolf: Hallo Uli, ich bin auf W7 auf W10 umgestiegen und hatte wieder die... 14. August 2016
  • Seba: Funktioniert nicht mit der aktuellen Version von VLC 2.2.4 Weder mit der... 6. Juli 2016

Archiv

Archiv für November 2009

Nach meinem Update von XAMPP auf die Version 1.7.2 und dem dort mitgelieferten PHP 5.3 bekam ich die Fehlermeldung:

Deprecated: Function split() is deprecated in …

Also habe ich meinen Code PHP 5.3-Kompatibel umgeschrieben. Da ich hier keine regulären Ausdrücke benutze habe ich die Funktion split() einfach durch explode() ersetzt. Hierbei erspare ich mir gegenüber preg_split() den Overhead für die Verarbeitung von regulären Ausdrücken. Diese hat sogar den Vorteil, dass sie schneller arbeitet als split(). Hätte ich reguläre Ausdrücke benötigt, so hätte ich natürlich die Funktion preg_split() benutzt. Auch diese ist fast immer schneller als split().
Split() ist also zu rechtens auf deprecated gesetzt 😉

Ich habe XAMPP in der Version 1.7.2 installiert und bekam bei meinen PHP-Projekten plötzlich die folgende Fehlermeldung/Warning:

Warning: mktime() [function.mktime]: It is not safe to rely on the system’s timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected ‚Europe/Paris‘ for ‚1.0/no DST‘ instead

Da ich wusste, dass mit dieser XAMP-Version auch auf PHP 5.3.0 geupdatet wurde habe ich direkt mal in die PHP.ini geschaut. weiter lesen…